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Using this guide 

This guide is not intended to be a full manual for p:IGI+, but is designed to 
illustrate the main features that are currently implemented. We are trying to 
make p:IGI+ sufficiently intuitive that a full user guide is not needed. 

 

To get the most out of this guide we would strongly advise you to also view the 
accompanying videos we have made to demonstrate key features in p:IGI+. 
These can be found at: http://www.igiltd.com/pigiplus-videos.html 

 

Also to assist with getting starting with p:IGI+ quickly we have also compiled a 
p:IGI+ Demo File. This can be downloaded from the IGI web site. 

 

All content in this guide is linked. Using the Guide contents page simply click the 
information desired. To return to the Guide Content simple click:  
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Guide contents 
• Introduction 
• Logging & the reporting of errors  
• p:IGI+ Screen Layout  
• p:IGI+ Demo Project File 
• Your data in p:IGI+ 

• The p:IGI+ data model 
• p:IGI-3 to p:IGI+ data model 

• Working in p:IGI+ 
• Introduction 
• Importing data from text files 
• Project properties 
• Importing data from IGI-2/3 files 
• Opening p:IGI-3 projects 
• Setting up Data Views (pages) 
• Undo in p:IGI+ 
• Spreadsheet appearance and features 
• Project data overview 
• Cleaning up your data 
• Merging in p:IGI+ 
• Sample sets in p:IGI+ 
• Templates in p:IGI+ 

 
 

 

• Wells in p:IGI+ 
• Introduction 
• Wells: location 
• Wells: depth 
• Wells: deviation survey 
• Wells: temperature 
• Wells: stratigraphy 

• Viewing your Data in p:IGI+ 
• Introduction 
• Creating graphs 
• Autographs 
• Working with scatterplots 
• Editing overlays 
• Working with brushing & visual 

query 
• Creating palettes 
• Working with palettes 
• Maps 
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• p:IGI+ remains in active development 
– we are providing this preview release to enable users to gain 

familiarity with p:IGI+ and provide feedback on recent 
developments 

• Many new features are present 
– and most p:IGI-3 functionality is still supported 

• We have focussed on usability and functionality 
– we have tried to make all actions have direct effects, with 

less need to apply or remember to calculate 
• you will see the impact of changes propagate throughout the system 

– undo is supported across the application 
– we are aware that there is still work to do 

• you might find some areas are not perfectly responsive and you need 
to wait a little for the application to catch-up 

• graphs are still in active development 
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Introduction 
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• In the unlikely event of encountering a problem we’d really appreciate 
you notifying us – sending all issues to: pigiplus@igiltd.com   

• From the Help -> View logs … menu item you can see any issues 

• It is simple to save the log file, save all log files or clear the logs to start 
afresh 
– when sending us a log file it would be very helpful if instructions on how to 

reproduce the issue were also included if possible 

 

5 

Logging and the reporting of errors 
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p:IGI+ Screen Layout 

Conventional 
Windows menu 

Toolbars for most 
common actions 

Artefact Manager 
with folders for 

graphs, pages, etc. 

Information / notification area 

Project workspace 
Used to open data 

views & graphs 
(windows not fixed 

to this space) 

Artifact Manager 
filters 
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p:IGI+ Demo Project File 

Venture H-22 

Bluenose 2G-47 

Terra Nova K-08 Voyager J-18 

South Tempest G-88 

Trave E-87 

Scotian Basin 

Well / Basin No. of Samples 

Bluenose 2G-47 694 

Venture H-22 348 

Scotian Basin 1042 

South Tempest G-88 396 

Terra Nova K-08 547 

Trave E-87 496 

Voyager J-18 447 

Jeanne D'Arc Basin 1886 

Taken from our recently expanded 2015 East Coast Petroleum commercial geochemical database 
(49,800 samples from 270 wells) a small subset consisting of ~3,000 samples from 6 wells located in 
adjacent basins has been complied into a p:IGI+ demonstration dataset. Both Basins contain 
samples covering Cenozoic & Mesozoic stratigraphy 
 
Some key observations which can be taken from the Demo Project File while exploring it are 
presented on the next slide 

Map taken from p:IGI-3 
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p:IGI+ Demo Project File 
• Data from both basins include a variety of samples types including rock cuttings, rock 

extracts, recovered oils, and optical maturity samples. This enables effective source 
rock screening, maturity, palaeo-environment and source oil correlation assessment to 
be conducted (biomarker/isotope analysis is absent from the dataset) 

• Geochemical differences in relation to organic matter type & quality between the two 
basins are stark due to the palaeo-geography and subsequent environmental redox 
conditions present at the time of deposition 

• Burial and thermal histories between the two basin have also differed with Scotian 
Basin Mesozoic samples located 2km deeper than seen with age equivalent samples in 
the Jeanne d’Arc basin. This produces completely different petroleum risk assessments 
between the two basins especially with regards to generation timing / trapping etc... 

• Both basins have discovered oil and correlate well against respective Mesozoic 
kerogen types present. In the Scotian Basin, a maturity difference between basin fluid 
and the sampled source rock cutting samples is also noted which could see the Early 
Cretaceous as an important interval of interest 
 

• Given the demo dataset and the capabilities of p:IGI+ the observations and 
interpretations can all be replicated through a combination of available Autographs, 
Sample sets and creating new graphs with associated underlays and palettes 



Your data in p:IGI+ 

This section focusses on the p:IGI+ data model, 
describing the basis for this what this means in 

practice, how we have mapped 
properties/data from p:IGI-3 and the impact 

that these changes might have 
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       Basic p:IGI + data model in pictures 

Project 
Well 

Sample 

Analysis Property 

Values 
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        Basic model in p:IGI+ 
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The project is a container for all your 
data (samples) and artefacts (graphs, 
palettes, sample sets, wells etc) 

The sample is the most basic 
element, representing the solid, 
liquid or gas that is of interest. 

A well is a mechanism for 
grouping samples and contains 
information on depth, datums 
etc. 

A sample is subject to analyses, each of 
which can generate multiple values for a 
range of properties 

A property is something that is 
measureable and is physically or 
chemically meaningful 

Values are the results 
of the measurements 
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Properties in p:IGI+ 

• We have defined 
>1500 common 
properties  
• in the short term IGI 

can add further 
properties if needed 
 

p:IGI+ does not have a 
limit on the number 
of properties available 

• Developed a series of 
substitution rules to 
make easy to use 
• e.g. TOC.Any 

• but can be precise 
• e.g. TOC.Leco 

Analysis groups mean 
properties can be 
measured many ways 
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Analysis groups supported in p:IGI+ 

• Screening 
– bulk oil, bulk PVT 

(density, pour point, 
wax content) 

– chemical properties, 
metals, sulphur content  

– RE, visual kerogen 
(transmitted and 
reflected, VR, maturity) 

– gas, PVT 

– water analysis 

– physical rock 

• Med/high res 
– extraction 

– sara and *LC 

– elemental, isotopes 

– GC (WO, PY, TE, SAT, HT) 

– GCMS ( WO, SAT, ARO) 

– GCMSMS (BIO) 

– GCIRMS 

– gas analysis, gas 
isotopes 

– PVT (still developing) 
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p:IGI-3 to p:IGI+ data model: Properties 

• You got familiar with the order of 
properties on the pages 

• this has changed in p:IGI+ 

• User columns were used to add 
new ‘properties’ 

In p:IGI-3 we 
had columns 

• All p:IGI+ pages are ‘custom’ pages 

• we recommend you retain the 
IGI structure for the analysis 
pages 

• A property is identified by: 

• Property.Analysis[Unit] 

• can easily search in property 
selection dialogue 

• Key is to remember that in p:IGI+ 
everything is a view on the data! 

 

In p:IGI+ we 
have properties 
and analyses 

•In the future users will be able to add new properties  which will fully integrate with 
p:IGI+, using the ig.Share system 

14 
p:IGI+ user guide (Sept 2015)  



p:IGI-3 to  p:IGI+ data model: Wells 

• You had to make a separate well 
manager file, and then apply this in 
p:IGI-3 

• updating was not simple 

• datums were not managed 

p:IGI-3 had well 
manager as a 
separate application 

• A well in p:IGI+ can store lots of 
information 

• datums, MD-TVD mappings 

• tops, logs 

• These are integrated so if you 
change something in a well it will 
affect other things 

• e.g. changing the formation top 
depths will re-assign the relevant 
sample stratigraphy 

• changing a datum will recalculate 
all depths interactively 

 p:IGI+ has an 
integrated well 
concept 
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•Replacement of values depends on settings – computed values are automatically over-
written, entered values are optional over-written (by deletion of the entered values) 
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p:IGI-3 to p:IGI+ data model: Molecular data 

• By molecular data we mean GC, 
GC/MS and GC/MS/MS data 

• This was spread across many pages 
in p:IGI-3 

• Not always terribly logical 

• Used the units to define height / 
area /  concentrations, causing 
confusion 

• Import from p:IGI-3 to p:IGI+ of 
molecular data is challenging 
because of the complexity of these 
mappings 

p:IGI-3 had pages for 
molecular data 

• Many molecular properties included 
(600+) 

• can be measured by wide range of 
analyses 

• We have a property indicator for 
molecular data 

• Property[Indicator].Analysis [Unit] 

• height, area, concentration (h, 
a), unknown 

• can now store all GC* data 

• units are a separate issue 

 

In p:IGI+ we have 
completely reviewed the 
molecular properties 
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•p:IGI-3 molecular data is imported into p:IGI+ with an unknown property indicator by 
default 
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p:IGI-3 to p:IGI+ data model: Gas data 

• Gas data is naturally complicated 

• there are a range of types of gas data, 
which measure different aspects of the 
gases 

• Units were used to identify the type of gas 
data, but this suggested conversion was 
possible! 

p:IGI-3 had pages for 
gas data 

• Gas data is split into two main types 

• sample gas (headspace / isotube etc) 

• mud-gas logs (planned feature) 

• We have a property indicator for gas data 
too 

• Property[Indicator].Analysis [Unit] 

• volume, mass, mole, or unknown 
fraction 

• again, units are separate issue 

• conversion between indicators may be 
possible if complete mixture is known 

In p:IGI+ we have 
completely reviewed 
gas properties 
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•p:IGI-3 gas data is imported into p:IGI+ with an unknown property indicator by default 
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p:IGI-3 to p:IGI+ migration: Units and unit groups 

Most unit groups and units stay the same 

• mappings from p:IGI-3 to p:IGI+ should be fine for most properties 

Changes to fractional units 

• mass e.g. %wt, ppt (mg/g), ppm (μg/g), ppb (ng/g) 

• volume e.g. %vol, ppt (cm³/l), scf/bbl 

• mol e.g. %mol, ppt, ppm 

• conversion requires special functions 

Ratios (a/b, a/(a+b), b/a, b/(a+b)) are separated from the units 

• import of ratio formats assumes the default p:IGI+ ratio at present, except for p:IGI-3 
import which assumes the data is always stored as (a/b) which is true in p:IGI-3 files 

Can only convert between units within the same unit group: 

• e.g. Unitless, Mass Ratio, Volume ratio, Mol ratio, Isotope ratio, Length, Temperature, 
Pressure, Mass, Density, Volume, Flow rate, Permeability, Conductivity, Velocity, Time, 
Thermal Conductivity 

• the dimensionless natural unit is called the Euclid [Euc] 
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Working in p:IGI+ 

This section reviews the core functionality in p:IGI+  

While not exhaustive; many minor features and 
capabilities are not highlighted, it reflects the preview 

release status of p:IGI+ 
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• The start point to working with p:IGI+ is either via: 
– a new blank project, into which data is imported 
– opening a p:IGI-3 project, which includes both project data and 

associated project artefacts e.g. graphs 
 

• Data can be imported via one of the following sources: 
– data import from a Text based Ascii file (supporting a range of formats) 
– data import from a p:IGI-3 file 

 

• Throughout the application the property selector is used to 
search and apply the appropriate properties to the task in hand. 
Search is possible via both Analyses & Properties for ease of use 
 
 
 
 
 
 

20 

Working with p:IGI+ Introduction 
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Importing data from Text files  
• Following Project > New  import can be found on the Project > Import 

data > menu item 
 

• Importing data from text files (ASCII) Project > Import data > Text file 
(ASCII) 
– p:IGI+ performs auto-encoding of your selected file layout and shows you a 

preview, but if it gets it wrong you can manually correct it 
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– Using aliases to help, p:IGI+ tries to link incoming properties to properties in the 
p:IGI+ property model 
• following initial auto linking any suggested link can be manually refined 

– During linking p:IGI+ tries to link both properties, and units if present 

– Filtering is used to focus on those links which p:IGI+ isn’t sure about or failed to 
link 

 

 

 

 

 

 

 

 

 
 

– Once happy with the linking you can save an import linking template 

– You can reset to the default linking too if you like 

 

 

Importing data from Text files  
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• Linking properties during import is a key stage 

– you can exclude columns from import if you are not sure  

– some will be auto-linked and you can review these and alter them 

– if a property has multiple link options to several analyses, the default will be 
chosen, but the others can be selected from a dropdown  

 

– if the property cannot be auto-linked you need to do this manually using the 
property selector 

– you can set the property indicator individually or as a bulk change (next slide), as 
well as the units and ratio 
• do not alter the ratio unless you are confident the ratio is different from the default provided 

– a visual indication is given if you alter any of the suggested mappings 
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Importing data from Text files  
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• Selecting properties uses the property selector, which is 
used throughout p:IGI+ 
– you can select using dropdowns for the analysis and then 

property, or simply type to search in the property box, which 
will bring a filtered list of properties with that string in them 
 
 
 
 
 
 

– you can also set the indicator, unit and ratio if they are 
applicable to the chosen property 

– if p:IGI+ does not contain the property you want to link to at 
import you can create a project property for this column (see 
next page) 

Importing data from text files - properties 
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• Project properties are new properties the user can create that exist only in that p:IGI+ 
project 
– however, if you save a template of an artefact that uses project properties, these properties are 

stored too, and on sending the artefact to another user / project the project properties are re-
created 
 
 
 
 
 
 
 
 
 
 

– you can create a range of types of project properties: 
• standard: normal observation with no indicator 

– can be numerical, in which case you assign units of measure, or text 

• gas: for gas data which includes indicators for the ratio (volume, mass, mol) 
• molecular: for GCxx data with indicators for area, height and concentrations 

– you can assign to any analysis group, but we recommend using the custom analysis group 
– you can give it a short and long name – short is used most widely, but the long name can be useful 

for search for it 

• Project properties are complete properties and will appear throughout the system just 
like the IGI properties, but only in that project / template 

Project properties 
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• The import summary shows you progress of the import (which can take some 
time for large data sets) and reports any errors: 
– errors in the data rows are reported in the activity summary, e.g. rows with too 

many or too few values or data values that could not be imported, e.g. text in 
numeric columns 

– any issues in merging well data (this is done on well name) where there are 
conflicts detected in the data being imported 

• You can also save a linking template here if you forgot to do that previously 

Import summary 
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Importing data from p:IGI-2/3 files 
• Importing data from a p:IGI-2/3 file: Project > Import data > IGI-2/3 

– Following a similar process to importing from a text file p:IGI+ will start by autolinking p:IGI-2/3 
properties to properties in p:IGI+ 

– you can redefine our mapping if you choose 
– When importing molecular and gas data, property indicators can be assigned on bulk 
– currently p:IGI+ does not support import of user columns due to the challenges in mapping them 
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Opening p:IGI-3 projects 
• An alternative to starting a p:IGI+ project from scratch is to open a currently created p:IGI-3 

project: Project > Open p:IGI-3 project 

• A new project (prompting the user to save the current project) is created and p:IGI-3 property 
data is imported as described in previous slide 

• Imported along with the data are:  

– Supported graphs (histograms, scatterplots and triplots) 

– Palettes (but only mapped to colour and size at present) 

– Graph Overlays (if in the right units) appear in the graph layer ‘Underlay’ (see Editing 
overlays) 

– Wells are created (see Section Wells in p:IGI+) 

• Sample sets are not yet imported 

• A report is generated for artefacts not imported correctly 
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Setting up Data Views (pages) 
• All views on the data model (pages) are user configurable 

– don’t edit analysis pages unless you really need to. Custom views of data 
properties can be created editing Interpretation views “User pages 1-5” 

• Right click on a page in artefact manager > Edit page … 

– select the properties you want to add either via analysis or search 

– multi-select (shift / ctrl), drag, drop & reorder with mouse, or use icons 

– set display precision, change the page name 
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• Undo is supported where this makes sense in p:IGI+ 
– Edit > Undo / Redo , Ctrl-z / Ctrl-y  to undo / redo , or icons 

– all data changes are undoable 

– most artefact changes are undoable (e.g. editing a palette, applying a palette to a 
graph) 

– some settings changes (e.g. page settings) are also undoable 

– if you undo an operation outside the current scope the ‘View Journals’ dialogue, 
which shows what you are about to undo. If happy to continue, re-execute the 
undo command 
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Undo in p:IGI+ 
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Spreadsheet appearance and features 
• Once imported data can be accessed through either Analysis or Interpretation 

views onto the data model e.g. Rock Screening 

• Column headers contain: properties, indicators, units and ratios, sample count 

 

 

 

 

 

 

 

 

 
 

• Spreadsheet special features: 
– all equations defined and auto-calculate on edit (delete user entered values to calculate) 

– copy, paste (Ctrl-c / Ctrl v), undo, redo (Ctrl-z / Ctrl-y) 

– Page > sorting (project wide), Toggle out of range data, key columns 

– deleting data: either (cell select , delete – delete cell contents) or (row select, right click, 
delete selected samples across all pages) 
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• The project data overview (was pixelmap) shows you where your data is in 
the project 
– red indicates data present – clicking on the pixel will tell you the property and 

sample 
 
 
 
 

 
 
 
 
 

– you can configure the project data overview to show any of the pages in the 
project 
• it is possible to have multiple project data overviews open at any time 
• drop a sample set on them to show a subset of samples 

– note the project data overviews are built dynamically and so respond to data 
changes 
• this means it is probably best to close them while editing 

• Future versions will offer enhanced functionality  

Project data overview 

32 p:IGI+ user guide (Sept 2015)  



• Data > Harmonise data for property 
– select a property to harmonise (type or select from dropdown), only shows valid properties 

– shows unique values in data, their frequency of occurrence, and allows you to choose or 
type a new value (auto-links by finding the closest string using an edit distance by default) 

– also shows the existing defined codes, and their defined aliases – for reference only 
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Cleaning up your data 
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• Unlike in p:IGI-3, merging samples happens inside p:IGI+ after import of all of 
your data 

• Data > Merge samples … 
– Select up to 5 merge criteria using the universal property selector  

– calculate the pre-merge summary to check the health of the intended merge 

– select whether you want to create a sample set of those samples that could not merge 
(merges with conflict) 

– merge is a bulk operation – more refined merge functionality is being developed in Metis 

– undo is supported 

– all open artefacts are closed 

      during the merge operation 

      for refresh 

 

 

 

Merge is a complex operation  

which can take some time 

to complete  
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Merging in p:IGI+ 
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Sample sets in p:IGI+ 
• p:IGI+ supports the creation and use of static sample sets  

• Data > Create new sample set  or Toolbar icons 

• Red cell outline informs user of fields required in order to proceed 

• A Sample Set can be defined by either individual numeric and string 
expressions or a combination of the two  

• Summary of expression values to be added to the sample set shown 
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Sample sets in p:IGI+ 

• Each expression element is 
given an ID of A .. Z 

• Complex sample set 
expressions can be created 
by combining expression 
element ID in the text 
expression editor 

• Expressions are created using 
the following rules: 

 

 

 

 

• The count of samples is 
dynamically updated 
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‘and’ ‘or’ 

‘not’ ‘inot’ 

Note that sample sets do not yet update 
automatically on data changes. This functionality is 
coming in the next release 



• Every artefact in p:IGI+ can be saved as a template to be shared with 
colleagues 

– right click on the artefact in the artefact manager & select “Export As Template…” 

• will export with any children, e.g. graph will include any palettes and overlays 

 

 

 

 

 

 

 
 

 

 

 

 
• Templates save their project properties with them; when you import a 

template p:IGI+ will first create the project properties, unless they already 
exist in the project 
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Templates in p:IGI+ 

– to import select Project > Import template… 
• can load in any p:IGI+ template,  
 and p:IGI-3 templates supported 
 (histograms, scatterplots, triplots, 
 palettes) 
• will build a new instance of the 
 artefact using the project data 
• can be used to add your own  
 new pages (save page as  
 template, then load in the 
 template – creates a new page)  
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Wells in p:IGI+ 

This section reviews using wells in p:IGI+  
 

This section should be used in conjunction with the video tutorials found 
at (http://www.igiltd.com/pIGIplus/) 

 

Also for quick start access to this section, use in conjunction with our 
p:IGI+ Demo Project 
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• Wells are integrated in p:IGI+ 
– found in the Artefact Manager > Base Wells folder by default 
– created on import using a simple ‘first value seen’ merge logic (other 

repetitions of well related values are ignored)  
• Can also be create within p:IGI+ (Data > Create new well... /                  ) 

– wells have a range of properties accessible from menu tabs 
– fully integrated and all calculations immediate 
– Any well property can be assigned to a data view under the analysis group 

‘Well’ 
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Using wells in p:IGI+ Introduction 

• Tabs: 
• basic info 

(Common) 
• Location 
• Depth 
• Well deviation 
• Temperature 
• Chronostrat 
• Drilling 

– more planned 
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• Georeferenced data is also accompanied by increasingly detailed textual information for 
location 

– can be useful for creating sample sets and palettes 

• Mapping is still being developed 

– currently rather simple but will be enhanced in the medium term 

– currently the choice of projections is limited, but in practice all widely used projections will be 
supported 
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Wells: Location 
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• Fully georeferenced location 

– both lat, lon and/or local 
coordinates X, Y can be 
stored 

– must specify the 
projection using EPSG 
codes 

– for lat, lon the most 
common default is the 
WGS84 geoid  



• Main depth tab allows you to specify used well datums 
– the reference absolute elevation datum is Mean Sea Level (normally) but can 

be LAT or a user datum (additional fields appear) 
– what is shown will depend on whether the well was assigned to be onshore or 

not (designated under the common tab) 
• offshore wells have water depth 
• onshore have ground elevation and optional river / lake depth 

– should also set the drillers reference elevation, typically the Kelly Bushing (KB) 
elevation 
• elevation (above the reference absolute elevation) or height (above ground level) is used 

for the drillers reference elevation 

41 

Wells: Depth 
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• Either a full well deviation survey and / or a set of tie-points can be stored in order to 
derive sample TVD from MD (and vice-versa if needed) 
– can select whether to use deviation survey or tie points in calculations 
– deviation survey required inputs are measured depth, deviation angle & deviation azimuth 

• can set datums and units for each 

– tie points as measure depth, true vertical depth pairs 
• can set datums and units for each 

– depths for all samples are only calculated when a defined datum and at least one well depth 
measurement is present for the property Base/Top MD.Sample 
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Wells: Deviation survey 
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*Values which are derived 
from other values appear 
shaded in green text 



• Well temperature measurements from both logging (raw & in need of Horner 
correction) and sampling (e.g. DST, RFT) can be stored in order to calculate an 
estimated thermal gradient 
– handles all depth conversions assuming data provided  
– computes a Horner correction for logging data where at least 3 given measurements and the 

circulation times are available  
– uses a Bayesian calculation to provide error bars on calculated thermal gradient 
– user must provide standard deviation of measurements (suggest a default of around 4 °C, 

depending on your confidence in the measurement) 
– dynamically populates the temperature column for samples 
– The Temp.Phys property can be used in plots against other thermal properties such as Pop1 

Mean.VR (vitrinite reflectance) 
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Wells: Temperature 
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• Well Chronostratigraphy is entered as a series of tops 
– can be added in any depth unit, datum, or type (TVD / MD) with 

depth conversion where data is available 

– can indicate whether surface is an unconformity (just for 
reference at present) 

– will dynamically allocate to samples; editing tops will reassign 
sample chronostrat 
• litho-strat is also supported in a very similar manner 
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Wells: Chrono- and Litho-stratigraphy 
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Viewing your data in p:IGI+ 
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This section how to effectively view and visually manipulate your data in p:IGI+  
 

This section should be used in conjunction with the video tutorials found 
at (http://www.igiltd.com/pIGIplus/) 

 

Also for quick start access to this section, use in conjunction with our 
p:IGI+ Demo Project File 

 
 

http://www.igiltd.com/pIGIplus/


Viewing your data in p:IGI+ Introduction 
• Extends the flexibility of p:IGI-3 

– more interactive, more intuitive 

– dynamic response to changes in data 

– longer term will also integrate with maps and models (e.g. PCA) 

• Scatter plot fully supported 
– fully interactive with palettes and sample sets 

• Histogram and Tri-plot supported to basic level 

• Graph manager provides more control over overlays and interaction 
with the graph 
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• Graph > Create new graph or use icon  

 

 

 

 

 

 

 

 

 
 

• Uses the property selector, plus you can set the property indicator, units and ratio 
where appropriate 

– select whether the axis is linear or log 

– select whether the vertical axis is inverted (e.g. for depth plots) 

• By default the default scatter plot is selected prompting the user to select the axes 

– filter button allows you to access & find specific autographs - (interpretative  subgroups) 

• Philosophy is to allow user to create graphs as quickly as possible, then edit them after 
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Creating graphs 
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*If an autograph 
is chosen then a 

preview is 
provided 



• Currently provides 24 scatter plot autographs covering a wide variety of geochemical 
disciplines have been incorporated into p:IGI+  

• They include a combination of previously popular p:IGI-3 plots but also highlight our 
ambition to include a new arrange of interpretative plots 
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Autographs 
  Graph Title Tags (interpretative sub-groups) 

1 TOC 0-30_Any vs S2_Pyrol Kerogen Potential 

2 TOC 0-80_Any vs S2_Pyrol Kerogen Potential 

3 Log TOC_Any vs S2_Pyrol Kerogen Potential 

4 TOC.Any vs S1.Pyrol: Oil Crossover Plot Kerogen Potential, Unconventional 

5 T-max_Pyrol vs HI_Pyrol Kerogen Quality, Maturity 

6 T-max_Pyrol vs HI_Pyrol (IGI) Kerogen Quality, Maturity 

7 Pseudo-Van Krevelen Diagram (IGI) Kerogen Quality 

8 Pseudo-Van Krevelen Diagram (Espitalie et al) Kerogen Quality 

9 Pseudo-Van Krevelen Diagram (Dembicki Jr.) Kerogen Quality 

10 Van Krevelen Diagram (Peters & Cassa) - mol Kerogen Quality, Maturity 

11 VR Pop1 vs Base MD_Sample_ft Maturity 

12 VR Pop1 vs Base MD_Sample_m Maturity 

13 Ph/nC18[un].WO-GC vs Pr/nC17[un].WO-GC Maturity, Environment 

14 C29 Sterane Isomerisation_SR vs IR Diagram Maturity 

15 Saturates_Aromatics vs Oil Gravity Maturity, Alteration, Environment 

16 
Bernard Diagram: Natural Gas & Shallow Bacterial-
Thermogenic Mixing 

Maturity, Gas, Migration, Alteration   

17 Ethane vs Methane_Gas Iso Maturity, Gas 

18 Wet Gas Type II Maturity Maturity, Gas, Migration 

19 Wet Gas Type III Maturity Maturity, Gas, Migration, Alteration   

20 d13C Saturates vs. d13C Aromatics (Sofer) Correlation, Environment 

21 Marine Oil Correlation Pr_Ph vs d13C Oil Correlation, Environment, Age 

22 Oil Family Correlation Pr_Ph vs d13C Sats Correlation, Environment 

23 PI_Pyrol vs T-max_Pyrol_IGI Unconventional, Generation 

24 PI_Pyrol vs. T-max_Pyrol Unconventional, Generation 
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*Not exhaustive, further autographs planned 
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Autographs 

• Through the use of newly included graph layers (Range underlay  / Underlay & Overlay) key 
interpretative components of graphs can be applied or turned off 
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• Graph > Graph manager... or icon 
• Graph manager controls interaction with 

currently selected plot (only ever one 
execution of it) 
– active graph is shown 
– default mode is pan/zoom to explore the 

graph 
• can change to rectangle zoom 

– can set axes limits manually 
– also store and recover zoom, and 

zoom to data extent 
– Brushing / Rectangle selection & Clear 

selection (appears when above selected) 
work across all plots, best without colour 
palette which includes red or similar colours  

 
• We will be adding more controls and tabs 

to enable better interaction with the plot 

50 

Working with scatterplots 

p:IGI+ user guide (Sept 2015)  



• The layout tab allows you to control the different 
layers and their visibility (Autograph Slides)  

– Layers include: 

• graph title (edit graph title) 

• image underlay to allow you to temporarily 
import images to guide overlay creation 

• range underlay is specifically to allow ranges 
on the x-axis to be shown  

• underlay sits below the data, and are suited to 
filled shapes 

• overlay sits above the data, and are suited to 
text labels  

– provides access to layer edit functionality when  
selected (Editing Overlays Slide)  
• also accessible from right click on the graph canvas 

– can also show / hide legends here 

51 

Working with scatterplots 
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• Overlay editor allows easy editing (while editing an overlay layer this is temporarily 
brought in front of the graph data – right click on the graph to access the editor) 
– select objects on graph or in list, drag and drop to control the draw order 
– edit graphically (green polycurve), or manually to get precise coordinates; object style 

can also be controlled 
– right click on graph to add objects (or use the icons) or delete (item needs to be 

selected: can also use delete key) 
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Editing overlays 
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*undo works throughout (Ctrl-z / y) 

– add labels to 
objects which will 
be shown in the 
legend 

– provide a title for 
the legend 
elements (blank if 
you just want a 
space) 

– select “Done” when 
finished 



Range underlays 

• Range underlays are designed 
to provide regions which extend 
‘infinitely’ vertically 

• They are most suited to 
histograms but can be used on 
scatterplots 

• Use the icon or right-click to 
add an x-range underlay 

• Provide an optional name for 
the legend for the range 
underlay 

• Provide names for the various 
classes in the range underlay 

• Edit the values either manually or using drag and drop on the grip points 

– add a new split, or delete and existing one using right click on the graph 

– change the colours using the colour picker 
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Image underlays 
1. Select the image underlay editor and 
click on the icon to add an image (or 
right click on the graph area) 

2. Select the image file to 
use with the file picker 

3. Define the section of the image to 
import using the grip points and the 
mouse 

4. Define the coordinates of the edges of 
the square being imported in graph 
units. Note that the edge being 
considered is highlighted as you edit the 
coordinate for that edge – this registers 
the image on your graph correctly 

5. Import the image overlay. Note this is 
temporary and will be lost if you close 
the graph or the project. 
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Working with brushing and visual query 

2. Brushed set highlighted 
red across all open graphs 

3. Visual query tool can be configured 
like page edit (drag and drop) 

5. Allows the 
selection to be 
cleared and the 
visual query tool 
to be started 

1. Can select a 
brush, or 
rectangle 
selection tool 

4. Currently explored sample 
highlighted with red box 
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• Graph > Create new palette or icon 
• Select new palette type (colour / size / 

shape) and select the property  
– edit the name 
– set the range and number of bins / size 

of bin (can change units) 
– decide where to put the anchor colours 

• can also use override colours to highlight a 
specific interval 

– Select whether to show only legend 
entries with data 

– say what to do with unassigned samples 
(values, but not in list) and samples with 
no data 

– when happy close the artefact with ‘x’ 
button – it will be added to the relevant 
base palette folder 

Creating palettes 
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Working with palettes 
Can access palettes on graph 
clicking on icons in graph title bar 

Can rename entries in 
legend label 

Drag and drop to define 
order for string values 

Applied palettes 
are shown on 
the graph tree 

… and in their 
respective base 
palette folders 

Changes are dynamically 
applied to the graph – can be 
used like a temporary sample 
set 

Size and shape palettes are separate 
palette types 
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• Maps are a developing feature in p:IGI+ 

Maps 

1. Create a 
new map 
using the icon 
to add an 
image (or the 
Map menu) 

2. Name the map, define the 
projection (limited options for 
now, suggest leaving at default 
or WGS84 – raw lat/lon). 
Define the coordinates (lat / 
lon). 

3. Create the map. Currently 
this displays the well locations, 
with names display on mouse 
over, and these can be double 
clicked to open the relevant 
well. 

We still have some work to do 
on maps. 
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